Partially Degraded Service

Incident Report for Rapid Global

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 16:44 ACST

Monitoring

A fix has been implemented and our team is monitoring the results, and Incident's performance. We will continue to update this page with new developments as they happen.
Posted Aug 25, 2026 - 14:51 ACST

Identified

Our team has identified the cause and is currently implementing a resolution. We’ll continue to monitor performance closely and provide further updates as needed.
Posted Aug 25, 2026 - 08:41 ACST

Investigating

Some users are experiencing intermittent slowness across Incident Reporting web application and reports.

Our team is investigating, we will provide further updates as soon as a cause is identified.
Posted Aug 24, 2026 - 12:09 ACST
This incident affected: Rapid Incident.